Help Support the Baja Engine! Donate to Breezeway Studios!

Baja Engine -> Forum -> Engine -> Engine General -> baja_foundation.js script error   |   [Search Forum]

baja_foundation.js script error - info on script error installing in XSI 6.01

New Post New Topic New Poll
tmshaw Posted: November 27, 2008, 8:16 PM quote

Newbie
*
Group: Testers
Member Id: 1950
Joined: Nov 26 2008
Posts: 0
Hello.
Just wanted to post this in case anyone else had this problem.
I am using xsi 6.01. I installed Baja engine as documented, but XSI reported an error in the Baja_foundation.js file. and wouldn't load.

To fix this, delete one (backslash) from the end first line of the Baja_foundation.js code. For example:

Original code that throws an error:
var directory = "C:Program FilesBaja Engine\";

Fixed code:
var directory = "C:Program FilesBaja Engine\";


pm  email   
tmshaw Posted: November 27, 2008, 8:20 PM quote

Newbie
*
Group: Testers
Member Id: 1950
Joined: Nov 26 2008
Posts: 0
Ok so this message board isn't letting me have multiple backslashes in a row in the message - that's why the previous post showed that the original code and fixed code were the same.

so I will type out the code using the word "backslash" where there should be some.

original code:
var directory = "C:(2 backslahes)Program files(2 backslashes)File(2 backslahses)Baja Engine(3 backslashes)";

fixed code, deleting one backslash:
var directory = "C:(2 backslahes)Program files(2 backslashes)Files(2 backslahses)Baja Engine(2 backslashes)";

Hope that makes sense.
pm  email   
New Post New Topic New Poll

Options